Categories
Marching

Apple’s MobileMe

Not entirely surprising considering those involved, but Apple’s latest web-based service, MobileMe, required “Safari 3, Internet Explorer 7, or Firefox 2 or later.” Apple is a high profile company, but not many others have the same savvy target market.

Know of any other company or web based service dropping IE6 support? Let me know.

Leave a Reply

Your email address will not be published.